Notices

2003 dodge ram 2500 5.7

Old 10-23-2015, 03:00 PM
  #1  
New Member
Thread Starter
 
Join Date: Oct 2015
Posts: 15
Likes: 0
Received 1 Like on 1 Post
2003 dodge ram 2500 5.7

I have a dodge ram 2500 5.7 changed everything pcm throttle body all sensor map sensor. But truck still don't idle correctly and and only stay running when foot on pedal checked fuel pressure its fine. Any help pls and changed cat to
Jentlee2 is offline  
Old 10-23-2015, 06:46 PM
  #2  
Mopar Lover
 
Join Date: Apr 2011
Posts: 4,284
Likes: 0
Received 382 Likes on 377 Posts
360 Magnaum ? What codes are you getting ?? That is the first place to start..
TVLynn is offline  
Old 10-23-2015, 07:18 PM
  #3  
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 7,470
Received 530 Likes on 523 Posts
I am with Lynn..... Why did we change all this stuff without pulling codes first ???
RacerHog is offline  
Old 10-24-2015, 07:59 AM
  #4  
New Member
Thread Starter
 
Join Date: Oct 2015
Posts: 15
Likes: 0
Received 1 Like on 1 Post
I get throttle body code .which I changed. Map sensor which I changed crank sensor which we changed and and getting key swipe code now after putting in new computer
Jentlee2 is offline  
Old 10-24-2015, 01:17 PM
  #5  
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 7,470
Received 530 Likes on 523 Posts
Everything in side the truck functions ok?
And all the Fuses are good in the power distribution box under the hood?

We need to make sure you dont have a communication error when plugged into the ALDL Connector..... That will have you chasing your tail for sure.

Also Can read if any of the drive cycles have been met?????

Post up the Codes..... I'm looking for one,,, But I'm not going to tell you what it is......lol
RacerHog is offline  
Old 10-24-2015, 03:21 PM
  #6  
New Member
Thread Starter
 
Join Date: Oct 2015
Posts: 15
Likes: 0
Received 1 Like on 1 Post
I called pcm place were I got it they put wrong 8 digit number at end of my vin number hopefully that's it will no Tuesday ty will let no
Jentlee2 is offline  
Old 10-24-2015, 04:23 PM
  #7  
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 7,470
Received 530 Likes on 523 Posts
Keep us posted....
RacerHog is offline  
Old 10-27-2015, 03:15 PM
  #8  
New Member
Thread Starter
 
Join Date: Oct 2015
Posts: 15
Likes: 0
Received 1 Like on 1 Post
Nope not.problem we have no idea fustrating
Jentlee2 is offline  
Old 10-27-2015, 03:38 PM
  #9  
New Member
Thread Starter
 
Join Date: Oct 2015
Posts: 15
Likes: 0
Received 1 Like on 1 Post
Put new pcm in. With right vin code and getting lighting bolt again and no codes can't drive to get codes
Jentlee2 is offline  
Old 10-27-2015, 06:22 PM
  #10  
Super Moderator
 
Iowan's Avatar
 
Join Date: Mar 2015
Location: Lost In Time!
Posts: 3,165
Received 179 Likes on 178 Posts
- check the grounds - all of them, make sure everything has ground.

Going back to your first post, I would look for a idle air control valve, these will stick closed not giving you an idle and not setting off a light/code.
Iowan is offline  
Old 10-28-2015, 09:18 AM
  #11  
New Member
Thread Starter
 
Join Date: Oct 2015
Posts: 15
Likes: 0
Received 1 Like on 1 Post
The control valve is in the throttle body which is brand new ty
Jentlee2 is offline  
Old 10-28-2015, 06:29 PM
  #12  
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 7,470
Received 530 Likes on 523 Posts
Ok.... Thats fine...... But do you have Communication from the ALDL to your scan tool? If not your fuse my be blown out in the distribution center under the hood...... The Black one should be the I.O.D. Fuse.... One of the yellows is Air Bags. The other one will run the B.C.M. One of those if blown will cause you lots of problems... Check and make sure thay are good.....

But we have to have communication to your scan tool before you can even get started....

One other thing..... It does have a good battery and alternator?

Last edited by RacerHog; 10-28-2015 at 06:36 PM.
RacerHog is offline  
Old 10-28-2015, 09:10 PM
  #13  
New Member
Thread Starter
 
Join Date: Oct 2015
Posts: 15
Likes: 0
Received 1 Like on 1 Post
Yes just bought a new battery and alternate is good
Jentlee2 is offline  
Old 10-29-2015, 05:42 AM
  #14  
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 7,470
Received 530 Likes on 523 Posts
Try to get some of the "drive cycle" done.... That way the PCM knows whats going on....
RacerHog is offline  
Old 10-29-2015, 05:52 PM
  #15  
New Member
Thread Starter
 
Join Date: Oct 2015
Posts: 15
Likes: 0
Received 1 Like on 1 Post
Can't really drive truck in limp mode and stalling
Jentlee2 is offline  
Old 10-29-2015, 06:40 PM
  #16  
Super Moderator
 
Iowan's Avatar
 
Join Date: Mar 2015
Location: Lost In Time!
Posts: 3,165
Received 179 Likes on 178 Posts
Your running out of options.
Iowan is offline  
Old 10-29-2015, 06:57 PM
  #17  
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 7,470
Received 530 Likes on 523 Posts
OK....How can we help you ?????
RacerHog is offline  
Old 10-29-2015, 07:42 PM
  #18  
New Member
Thread Starter
 
Join Date: Oct 2015
Posts: 15
Likes: 0
Received 1 Like on 1 Post
Have no idea just frustrating
Jentlee2 is offline  
Old 10-29-2015, 09:20 PM
  #19  
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 7,470
Received 530 Likes on 523 Posts
RacerHog is offline  
Old 10-30-2015, 11:53 AM
  #20  
New Member
Thread Starter
 
Join Date: Oct 2015
Posts: 15
Likes: 0
Received 1 Like on 1 Post
Yes exactly like that
Jentlee2 is offline  
Old 10-30-2015, 04:23 PM
  #21  
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 7,470
Received 530 Likes on 523 Posts
Pull the Valve cover and take a peek....
RacerHog is offline  
Old 11-07-2015, 11:01 AM
  #22  
New Member
Thread Starter
 
Join Date: Oct 2015
Posts: 15
Likes: 0
Received 1 Like on 1 Post
Ty racer we found problem multiple spring thing broken husband replacing them under valve cover
Jentlee2 is offline  
Old 11-07-2015, 04:06 PM
  #23  
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 7,470
Received 530 Likes on 523 Posts
You welcome.... Hope this cures the problem or at least most of it.....
Keep us posted....
RacerHog is offline  
Old 11-07-2015, 08:23 PM
  #24  
New Member
Thread Starter
 
Join Date: Oct 2015
Posts: 15
Likes: 0
Received 1 Like on 1 Post
Truck running ty ty tyvm
Jentlee2 is offline  
The following users liked this post:
RacerHog (11-08-2015)
Old 04-27-2016, 12:15 PM
  #25  
New Member
Thread Starter
 
Join Date: Oct 2015
Posts: 15
Likes: 0
Received 1 Like on 1 Post
We r having same problem after 4 mon ths they were fine now doing idle ruff again

Originally Posted by Jentlee2 View Post
Truck running ty ty tyvm
Having Sam problem changed springs 4 months ago and ran fine and now it's doing again
Jentlee2 is offline  
Old 04-27-2016, 12:17 PM
  #26  
New Member
Thread Starter
 
Join Date: Oct 2015
Posts: 15
Likes: 0
Received 1 Like on 1 Post
Ruff idle

Originally Posted by Jentlee2 View Post
Having Sam problem changed springs 4 months ago and ran fine and now it's doing again
It has ruff idle engine goes up and down
Jentlee2 is offline  
Old 04-29-2016, 05:35 PM
  #27  
Mopar Lover
 
Join Date: Apr 2011
Posts: 4,284
Likes: 0
Received 382 Likes on 377 Posts
Should have changed all of them, Get a good set from SummitRacing.com
TVLynn is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Jentlee2
General Technical Questions
1
10-23-2015 07:22 PM
elmorazer
New Members
5
02-23-2012 10:13 AM
puller
General Discussion
2
10-08-2010 03:41 AM
CantRamItDodgeIt91
94-Current Dodge Trucks
4
09-27-2010 10:34 PM
gary2010
94-Current Dodge Trucks
4
01-14-2010 08:26 PM


Thread Tools
Search this Thread
Quick Reply: 2003 dodge ram 2500 5.7


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.