Pump Noise - Mopar Forums

Pump Noise

Reply

 
 
 
Old 03-18-2012, 01:58 PM
  #1  
Member
Thread Starter
 
jar84203's Avatar
 
Join Date: May 2009
Posts: 85
Thanks: 0
Thanked 0 Times in 0 Posts
Pump Noise

I have a 02 Cruiser and after making a U-turn, I notice a whine coming from under the hood. Is this the PS pump and if so why does it whine after the turn is completed and the vehicle is traveling in a straight line? Thanks.
jar84203 is offline  
Reply With Quote
Old 03-18-2012, 04:08 PM
  #2  
Mopar Lover
 
blue 68 gts's Avatar
 
Join Date: Jan 2007
Location: Lynnhood, Wa
Posts: 1,117
Thanks: 0
Thanked 18 Times in 17 Posts
Possibly low on fluid, have you checked that?

Not sure, but a whacked out theory i came up with, if the valve in the rack got stuck one way, then there would be pressure to one side, nothing on the other. But then I guess that'd make it hard to steer and pull you in one direction or another.

I vote low fluid.
blue 68 gts is offline  
Reply With Quote
Old 03-18-2012, 05:35 PM
  #3  
Member
Thread Starter
 
jar84203's Avatar
 
Join Date: May 2009
Posts: 85
Thanks: 0
Thanked 0 Times in 0 Posts
Fluid is good.
jar84203 is offline  
Reply With Quote
Old 03-18-2012, 05:43 PM
  #4  
Mopar Lover
 
blue 68 gts's Avatar
 
Join Date: Jan 2007
Location: Lynnhood, Wa
Posts: 1,117
Thanks: 0
Thanked 18 Times in 17 Posts
Originally Posted by jar84203 View Post
Fluid is good.

Are the lines to the rack kinked?

Sounds like a bad rack or valve or bad pump.


Hard to diagnose noises without driving or having some sort of video..
blue 68 gts is offline  
Reply With Quote
Old 03-18-2012, 07:37 PM
  #5  
Member
Thread Starter
 
jar84203's Avatar
 
Join Date: May 2009
Posts: 85
Thanks: 0
Thanked 0 Times in 0 Posts
Upon visual inspection, everything appears fine (the lines weren't kinked).
jar84203 is offline  
Reply With Quote
Old 03-18-2012, 09:11 PM
  #6  
Mopar Lover
 
Join Date: Apr 2011
Posts: 4,267
Thanks: 0
Thanked 381 Times in 376 Posts
I would flush the pump / change the fluid.. Hook a hose to the return line while the engine is running slowly pour fluid in until it comes out clean.. Then reconnect
TVLynn is offline  
Reply With Quote
Old 03-19-2012, 09:32 AM
  #7  
Member
Thread Starter
 
jar84203's Avatar
 
Join Date: May 2009
Posts: 85
Thanks: 0
Thanked 0 Times in 0 Posts
I'll try flushing it today. So bad fluid can cause it to become noisy?
jar84203 is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
doug2060
Intrepid/Concord/Vision/300M
4
08-28-2010 04:33 PM
MichaelSB
General Technical Questions
3
08-16-2010 12:08 PM
JLanzino
A-Body
2
05-01-2009 06:58 PM
Valcam
General Discussion
3
05-01-2009 03:10 PM
mopar nate
B-Body
9
03-21-2009 09:16 PM
« WOW | - »


Thread Tools
Search this Thread