1970 Cuda 496 10,3 sec - Mopar Forums
 


Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 10-21-2013, 07:55 PM   #1
Mopar Fanatic
Thread Starter
 
Join Date: Oct 2013
Posts: 121
Thanked 1 Time in 1 Post
1970 Cuda 496 10,3 sec

Hello Guys ! Im Raf from Italy .. I have a 70 cuda with 500 ci .. Drag car ...in Italy .. We have 4/5 race at year .. My best ET is 10,[email protected] 1,53 60 ft ...this is my specs :
1970 cuda
440 bored at 4,36"
440 source 4.15 crank
H beam rod
All balanced
Ross flat top pistons 12:1 cr
Total max seal rings ..gapless top ring
Indyheads 295 ez all polished and CNC
Roller camshaft .670 lift
Roller rockers harland sharp 1,6
Cometic head gaskets multilayer
Indy single plane intake
1050 quick fuel carburetor
Shot nitrous +200 hp activated with delay box
Also 727 Transmission is build from mine
All drums billet
Billet pistons
Full manual valve body
5500 stall ultimate converter
Rear end is 8 3/4 with detroit locker with 4.10
Stock leaf springs
Caltracs zero preload
Subframe connector
Rear shock is qa1 all soft
Front drag shock 90/10
Tires is 28/10,50/15 MT drag slick

Best Et 10,[email protected] 1.53 60 ft

My goal is 9,90 ... With nitrous activation before .. And monoleaf !

Will be happy for any advice !!

Thanks !
raffaplymouth is offline   Reply With Quote
Old 10-22-2013, 12:26 AM   #2
Mopar Fanatic
 
John Van's Avatar
 
Join Date: Jun 2009
Location: Rensselaer,New York
Posts: 428
Thanks: 0
Thanked 8 Times in 7 Posts
Raf, welcome to the forum! Everything sounds good,what does the car weigh? How many passes have you made? I am surprised that 8 3/4 rear has survived! You might want to get a dana60 or ford 9" in there

john.
John Van is offline   Reply With Quote
Old 10-22-2013, 11:23 AM   #3
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 5,717
Thanked 427 Times in 423 Posts
Welcome....Welcome.... Raffa!!!!!!!!

Good to see you here Raffa.... Welcome to the Site......
RacerHog is offline   Reply With Quote
Old 11-01-2013, 10:46 PM   #4
Mopar Fanatic
Thread Starter
 
Join Date: Oct 2013
Posts: 121
Thanked 1 Time in 1 Post
Quote:
Originally Posted by John Van View Post
Raf, welcome to the forum! Everything sounds good,what does the car weigh? How many passes have you made? I am surprised that 8 3/4 rear has survived! You might want to get a dana60 or ford 9" in there

john.
Car weight is 3400 lb ! Around 50 pass with this engine .. Now is dysassembled for refresh ... Oil leak from valve steam .. I dont know if this is caused from too toluene in the gasoline ... Also exhaust valves is wear .. I think for nitrous oxide ?? Yes John 8 3/4 with this horses no problem for now !! Side shafts stock , wheel bearings stock , only ring and carrier detroit locker !! My best 60 ft is 1.53 ... I will post some pictures of engine dysassembled for refresh .
raffaplymouth is offline   Reply With Quote
Old 11-02-2013, 08:36 AM   #5
Mopar Fanatic
 
Join Date: Apr 2013
Location: Elk Grove, CA
Posts: 181
Thanked 17 Times in 17 Posts
Quote:
Originally Posted by raffaplymouth View Post
Car weight is 3400 lb ! Around 50 pass with this engine .. Now is dysassembled for refresh ... Oil leak from valve steam .. I dont know if this is caused from too toluene in the gasoline ... Also exhaust valves is wear .. I think for nitrous oxide ?? Yes John 8 3/4 with this horses no problem for now !! Side shafts stock , wheel bearings stock , only ring and carrier detroit locker !! My best 60 ft is 1.53 ... I will post some pictures of engine dysassembled for refresh .
Welcome Raffa,

That sounds like some animal of a car you got!! I take it, it's not streetable?

Post of some pics soon
inri is offline   Reply With Quote
Old 11-19-2013, 12:45 AM   #6
Mopar Fanatic
Thread Starter
 
Join Date: Oct 2013
Posts: 121
Thanked 1 Time in 1 Post
Quote:
Originally Posted by inri View Post
Welcome Raffa,

That sounds like some animal of a car you got!! I take it, it's not streetable?

Post of some pics soon
raffaplymouth is offline   Reply With Quote
Old 11-19-2013, 12:46 AM   #7
Mopar Fanatic
Thread Starter
 
Join Date: Oct 2013
Posts: 121
Thanked 1 Time in 1 Post
raffaplymouth is offline   Reply With Quote
Old 11-19-2013, 12:48 AM   #8
Mopar Fanatic
Thread Starter
 
Join Date: Oct 2013
Posts: 121
Thanked 1 Time in 1 Post
raffaplymouth is offline   Reply With Quote
Old 11-19-2013, 12:50 AM   #9
Mopar Fanatic
Thread Starter
 
Join Date: Oct 2013
Posts: 121
Thanked 1 Time in 1 Post
raffaplymouth is offline   Reply With Quote
Old 11-19-2013, 12:54 AM   #10
Mopar Fanatic
Thread Starter
 
Join Date: Oct 2013
Posts: 121
Thanked 1 Time in 1 Post
raffaplymouth is offline   Reply With Quote
Old 11-19-2013, 12:58 AM   #11
Mopar Fanatic
Thread Starter
 
Join Date: Oct 2013
Posts: 121
Thanked 1 Time in 1 Post
raffaplymouth is offline   Reply With Quote
Old 11-19-2013, 01:04 AM   #12
Mopar Fanatic
Thread Starter
 
Join Date: Oct 2013
Posts: 121
Thanked 1 Time in 1 Post
raffaplymouth is offline   Reply With Quote
Old 11-19-2013, 05:44 AM   #15
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 5,717
Thanked 427 Times in 423 Posts
Car still looks and sounds great Raffa..... Is that still the Combo Motor you and Tom talked about?
1. video still looks like the car is spinning the tire?
2. Video Dose it look like that Tire is buckled in the middle about the middle of 2nd gear.

You are almost in the 9's Buddy !!!!!
RacerHog is offline   Reply With Quote
Old 11-19-2013, 07:31 AM   #16
Mopar Fanatic
Thread Starter
 
Join Date: Oct 2013
Posts: 121
Thanked 1 Time in 1 Post
Quote:
Originally Posted by RacerHog View Post
Car still looks and sounds great Raffa..... Is that still the Combo Motor you and Tom talked about?
1. video still looks like the car is spinning the tire?
2. Video Dose it look like that Tire is buckled in the middle about the middle of 2nd gear.

You are almost in the 9's Buddy !!!!!
yes Racerhog !! this is modality kill from Tom help !! Tom is my big friend !! i dont understand buckled in 2nd gear !! ?? my goal is 9.90 !!
raffaplymouth is offline   Reply With Quote
The Following User Says Thank You to raffaplymouth For This Useful Post:
RacerHog (11-19-2013)
Old 11-19-2013, 11:47 AM   #17
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 5,717
Thanked 427 Times in 423 Posts
Wondering if the slick has full contact with the Track?
Looking at the video. It looks like the tire my not be stuck to the track?
RacerHog is offline   Reply With Quote
Old 11-19-2013, 06:54 PM   #18
Mopar Lover
 
Join Date: Nov 2012
Posts: 1,846
Thanked 138 Times in 137 Posts
just an idea about "exhaust valves wear" 1. might be a bad valve job. 2. the super hi lift cam will strain the valves a lot. 3. or you are turning the engine to hi speed. try lowering the top RPM.
moe7404 is offline   Reply With Quote
Old 11-19-2013, 06:58 PM   #19
Mopar Lover
 
Join Date: Nov 2012
Posts: 1,846
Thanked 138 Times in 137 Posts
realy? traction bars no a race mopar? you need to do your research how to build a mopar race car.
moe7404 is offline   Reply With Quote
Old 11-19-2013, 08:07 PM   #20
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 5,717
Thanked 427 Times in 423 Posts
Easy Moe....... He drives this on the Street also....
Just wait till he posts up some of the cars he has done..... Raffa Dose beautiful work...

Last edited by RacerHog; 11-19-2013 at 08:10 PM.
RacerHog is offline   Reply With Quote
The Following User Says Thank You to RacerHog For This Useful Post:
raffaplymouth (11-19-2013)
Old 12-08-2013, 12:43 AM   #21
Mopar Fanatic
Thread Starter
 
Join Date: Oct 2013
Posts: 121
Thanked 1 Time in 1 Post
[QUOTE=RacerHog;111846]Easy Moe....... He drives this on the Street also.... yes Tom , Car is ready for the next years season , my goal is 9.90 , but i have problem with nitrous activation delay , doesn't work very well , when i release the gas , restart the countdown and the nitrous will active almost at finish line !!! this is not good !! , another problem is the oil pressure .. look like at idle ( 70 psi ) is better than at 7500 rpm is 60 psi ... i dont know this ... is not very good ...


this is the video of timing tune up

Last edited by raffaplymouth; 12-08-2013 at 12:47 AM.
raffaplymouth is offline   Reply With Quote
Old 12-08-2013, 11:39 AM   #22
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 5,717
Thanked 427 Times in 423 Posts
Raffa....Add one more Quart of engine oil to the engine and see if that helps.. The problem "Might" be the High Volume oil pump is sucking most of the oil out of the pan and it is not returning back down fast enough....

AS for the Nitrous activation problem..That you have got to fined the problem.
That is bad!!

Are you running the MSD electronics for your NOS System?

Sorry... I dont remember all of your set up, it was all over on "Mopartech" but now that it is gone, I have to go by my memorie.....lol
RacerHog is offline   Reply With Quote
Old 04-13-2014, 08:24 AM   #23
Mopar Fanatic
Thread Starter
 
Join Date: Oct 2013
Posts: 121
Thanked 1 Time in 1 Post
Quote:
Originally Posted by RacerHog View Post
Raffa....Add one more Quart of engine oil to the engine and see if that helps.. The problem "Might" be the High Volume oil pump is sucking most of the oil out of the pan and it is not returning back down fast enough....

AS for the Nitrous activation problem..That you have got to fined the problem.
That is bad!!

Are you running the MSD electronics for your NOS System?

Sorry... I dont remember all of your set up, it was all over on "Mopartech" but now that it is gone, I have to go by my memorie.....lol
External oiling system

raffaplymouth is offline   Reply With Quote
Old 04-13-2014, 08:27 AM   #24
Mopar Fanatic
Thread Starter
 
Join Date: Oct 2013
Posts: 121
Thanked 1 Time in 1 Post
raffaplymouth is offline   Reply With Quote
Old 04-13-2014, 08:28 AM   #25
Mopar Fanatic
Thread Starter
 
Join Date: Oct 2013
Posts: 121
Thanked 1 Time in 1 Post

Last edited by raffaplymouth; 04-13-2014 at 08:40 AM.
raffaplymouth is offline   Reply With Quote
Old 04-13-2014, 08:31 AM   #26
Mopar Fanatic
Thread Starter
 
Join Date: Oct 2013
Posts: 121
Thanked 1 Time in 1 Post
Quote:
Originally Posted by RacerHog View Post
Raffa....Add one more Quart of engine oil to the engine and see if that helps.. The problem "Might" be the High Volume oil pump is sucking most of the oil out of the pan and it is not returning back down fast enough....

AS for the Nitrous activation problem..That you have got to fined the problem.
That is bad!!

Are you running the MSD electronics for your NOS System?

Sorry... I dont remember all of your set up, it was all over on "Mopartech" but now that it is gone, I have to go by my memorie.....lol
Bob .. 1 quart more ?? and wich oil you advice me ?? i have installed now external oiling .. you like ?? .. now i use 10w60 Castrol edge .. but i can have also Valvoline VR1 racing
raffaplymouth is offline   Reply With Quote
Old 04-13-2014, 08:38 AM   #27
Mopar Fanatic
Thread Starter
 
Join Date: Oct 2013
Posts: 121
Thanked 1 Time in 1 Post
Quote:
Originally Posted by RacerHog View Post
Raffa....Add one more Quart of engine oil to the engine and see if that helps.. The problem "Might" be the High Volume oil pump is sucking most of the oil out of the pan and it is not returning back down fast enough....

AS for the Nitrous activation problem..That you have got to fined the problem.
That is bad!!

Are you running the MSD electronics for your NOS System?

Sorry... I dont remember all of your set up, it was all over on "Mopartech" but now that it is gone, I have to go by my memorie.....lol
Bob ..i see now your question !! yes MSD 6 AL with timing retard , nitrous is 200 HP with 95-102 jet killer mode !!

Tom for oil return i have drilled all windage tray .. can add 1 quart more ?
raffaplymouth is offline   Reply With Quote
Old 04-13-2014, 09:39 AM   #28
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 5,717
Thanked 427 Times in 423 Posts
Raffa... If you/we think the oil is all getting sucked out of the oil pan.. you can add 1 more quart of oil to see if the problem goes away. If the pressure gets better. Then you know the engine was under oil capacity and that would explain the drop/loss.

Yes I like the External Pump.... Leaves room for the bigger stroke crank and rods...

I'm Not Much into Multigrade oil.....
I like 30W or 40W... Racing.... I use Castrol... But nothing wrong with VALVOLINE VR.
I think it holds its viscosity better when we beat the **** out of it....
But thats just my opinion....

You got the NOS Fixed?

Did you install the CAL-Trac's?

Hope you have a great season of racing..And get that 9.90...
RacerHog is offline   Reply With Quote
Old 04-13-2014, 10:32 AM   #29
Mopar Lover
 
Join Date: Apr 2011
Posts: 4,071
Thanks: 0
Thanked 365 Times in 360 Posts
If an extra qt of oil does not help ? I would try adjusting the pressure relief valve When cold ! it is Ok but when hot . the oil thins and the oil pressure relief releases at 60 psi ????
TVLynn is offline   Reply With Quote
Old 04-13-2014, 10:37 AM   #30
Mopar Lover
 
Join Date: Apr 2011
Posts: 4,071
Thanks: 0
Thanked 365 Times in 360 Posts
Great car !!!
TVLynn is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Low 9 sec Cuda .. 28x10x15 or 29.5x10x15 ? raffaplymouth Street n Strip 25 01-05-2016 04:08 PM
496 stoker 440 aspen Engines, Exhaust and Fuel systems 6 03-23-2014 03:00 AM
383 to 496 stroker walbey Engines, Exhaust and Fuel systems 3 09-23-2011 04:50 AM
need help with 383 stroked and bored to 496 wyattmerk General Technical Questions 7 12-01-2008 05:19 AM
1970 Cuda ... Strange tail lights?!!??!! mamapeep General Discussion 1 05-12-2008 05:37 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 09:34 PM.