Throttle bracket problem - Mopar Forums

Go Back  Mopar Forums > GENERAL > Engines, Exhaust and Fuel systems
Throttle bracket problem >

Throttle bracket problem

Notices
Engines, Exhaust and Fuel systems
Sponsored by:
Sponsored by:

Throttle bracket problem

Old 01-13-2019, 11:00 PM
  #1  
New Member
Thread Starter
 
Join Date: Sep 2018
Location: SoCal
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Throttle bracket problem



Help! Need a few pics of throttle linkage.

Story below but a simple job got increasingly complicated and now I canít get it back together.

Started a small project; installing an EGR valve for Smog inspection. Noticed aluminum intake was filthy. Tried cleaning it up. Decided to clean waterneck and install thermostat. Took off throttle linkage planning to put it back. It was greasy so took it off to clean and spray. The carb wouldnít clear EGR. Bought a spacer.. now canít figure out what I did with throttle linkage. I believe I may have moved it back one bolt location but not finding May pics in other posts.

Any snap shot of brackets, location, and setup would be very helpful.

this is a 79 W150. 360 auto.
Rod1701 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Myraman
Engines, Exhaust and Fuel systems
12
09-13-2013 06:55 AM
degausser86
Engines, Exhaust and Fuel systems
7
07-29-2012 09:08 PM
roadrun383
B-Body
5
03-11-2009 01:36 PM
Mixmastermerrill
A-Body
2
08-21-2008 04:13 AM
Stockdog
General Discussion
0
11-03-2007 07:52 AM


Thread Tools
Search this Thread
Quick Reply: Throttle bracket problem


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.