AC Not Blowing - Mopar Forums
 


Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 08-09-2018, 10:19 AM   #1  
New Member
Thread Starter
 
Join Date: Aug 2018
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Angry AC Not Blowing

Hey all- first post here.

I have a 2013 2.0L Limited Dart and am having some issues with the AC. A few months ago, my AC just cut out. At first it was only every other day it would cut out and then it stopped working all together. Let me kind of tell you what I am experiencing.

When driving (now), I can get SOME air to blow by putting my AC on full blast, circulation, MAX AC. It only blows a little bit but will only do this when the car is moving. If the car is in idle or stationary it will not blow anything.

Here is the weird part, sometimes, only sometimes, I will get full control back. The most recent time was last week. I was driving on the interstate (I had to have been on hour three or four) when the damn thing kicked back on. I had temperature control, speed control, the whole shabang. Not surprisingly, as soon as I parked at my destination and turned the vehicle off, my all-control power went away.

I have changed the cabin air filter, pulled the fuses, checked the fan to make sure its clear of any obstructions— I have done everything I can think of.
So I am stumped, anyone have any advice?

Thanks guys
czubernis is offline   Reply With Quote
Old 08-09-2018, 12:39 PM   #2  
Super Moderator
 
Iowan's Avatar
 
Join Date: Mar 2015
Location: Lost In Time!
Posts: 2,382
Thanked 138 Times in 138 Posts
Did you change the fuse/breaker at the time you checked it?
I would change it for new
Iowan is online now   Reply With Quote
Old 08-10-2018, 05:35 AM   #3  
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 6,751
Thanked 490 Times in 486 Posts
Sounds to me like you have some failure in the blend door motors...
RacerHog is offline   Reply With Quote
Old 08-10-2018, 08:00 PM   #4  
Mopar Lover
 
Coronet 500's Avatar
 
Join Date: May 2011
Location: Ontario Canada
Posts: 2,304
Thanks: 0
Thanked 247 Times in 237 Posts
Could this be simply a low voltage battery that charges up on a long drive then stuff starts to work.
Coronet 500 is offline   Reply With Quote
Old 08-15-2018, 05:22 AM   #5  
Mopar Fanatic
 
ZEN357's Avatar
 
Join Date: Feb 2018
Posts: 112
Thanks: 0
Thanked 9 Times in 9 Posts
I would check the relays, and the door motors.
ZEN357 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
360 blowing back through carburetor. Dave E Engines, Exhaust and Fuel systems 13 11-01-2015 09:46 AM
Blowing smoke clouds Durango-Tango Engines, Exhaust and Fuel systems 6 10-09-2012 08:06 PM
Blowing Tranny Fluid out the dipstick tube retired Transmissions, Transfer Cases and Rear Ends 1 07-18-2012 04:57 PM
AC not blowing cold.. ddunk80 General Discussion 1 06-18-2011 02:28 AM
Keep blowing starter relay! dodgecharger72 General Technical Questions 5 09-22-2009 07:26 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 04:11 PM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.