Ignition coil help - Mopar Forums

Ignition coil help

Reply

 
 
 
Old 11-04-2018, 10:08 AM
  #1  
New Member
Thread Starter
 
Join Date: Nov 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Ignition coil help

Hi all, I have an 86 w100 318, on the way home from work truck started idling weird. When on the throttle truck was sluggish and felt like it was lurching when under a load. Got home shut it off and she wont start anymore. It tries to fire but sounds like ****. Carb has been rebuilt shoots fuel when you try to crank and when you give her gas. I'm getting fire but where I'm stumped at is the igntion coil has a random extra wire on the positive side that is hot when the key is on. Dunno what it hooks into???? Help any suggestions?

Also found this sitting on the intake in the back any ideas??
Rusty86 is offline  
Reply With Quote
Old 11-04-2018, 04:37 PM
  #2  
New Member
 
Join Date: Nov 2018
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
that is radio noise suppressor. cuts down on static in radio. if that wire on pos side of coil was touching intake/ground it may be your problem. you may also now have to change resistor if equipped. they asked me how old i am and i said" i am so old that when we drove mopar in old days,a spare resistor was standard issue in glove box". also have had problem when aftermarket coil is used with std brain box.
rbkt65 is offline  
Reply With Quote
Old 11-04-2018, 04:39 PM
  #3  
New Member
 
Join Date: Nov 2018
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
also, did it jump time?
rbkt65 is offline  
Reply With Quote
Old 11-04-2018, 04:43 PM
  #4  
New Member
Thread Starter
 
Join Date: Nov 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by rbkt65 View Post
also, did it jump time?
is that possible just jumping ignition timing without messing with the distributor??? And I guess ill take that wire off when I get a chance thank you for the reply I dont have a radio so off with the wire. That's weird a radio static suppressor on the ignition coil positive side
Rusty86 is offline  
Reply With Quote
Old 11-04-2018, 04:44 PM
  #5  
New Member
Thread Starter
 
Join Date: Nov 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by rbkt65 View Post
that is radio noise suppressor. cuts down on static in radio. if that wire on pos side of coil was touching intake/ground it may be your problem. you may also now have to change resistor if equipped. they asked me how old i am and i said" i am so old that when we drove mopar in old days,a spare resistor was standard issue in glove box". also have had problem when aftermarket coil is used with std brain box.
or are you talking about that little cylinder????
Rusty86 is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Terpodion
General Technical Questions
7
11-23-2016 08:37 AM
Terpodion
General Technical Questions
0
07-03-2016 05:57 PM
labradorian70
Do-It-yourself Section
3
07-22-2014 09:56 PM
gkaucher
General Discussion
1
08-13-2012 06:32 PM
stazja01
General Technical Questions
3
11-17-2008 05:24 AM


Thread Tools
Search this Thread
Quick Reply: Ignition coil help


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.