Weird click sound when u turn the steering wheel - Mopar Forums
 


Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 09-29-2017, 10:08 PM   #1
Mopar Fan
Thread Starter
 
D4Dartswinger's Avatar
 
Join Date: Dec 2016
Posts: 45
Thanks: 0
Thanked 1 Time in 1 Post
Weird click sound when u turn the steering wheel

so when I'm driving as I turn left , on the first rotation there's like a knock or click sound. I can feel it in the steering wheel. Mostly happens when I turn left. Any ideas? . And sorry if this is a loaded question but I have a hole that the steering column goes into(causing lots of heat to hit my legs . I was told that this plate that the column goes through, that's on the inside of the car should be on the outside. This sound familiar to anyone? I'll post pics tomorrow.
D4Dartswinger is offline   Reply With Quote
Old 09-30-2017, 07:00 PM   #2
Mopar Fan
Thread Starter
 
D4Dartswinger's Avatar
 
Join Date: Dec 2016
Posts: 45
Thanks: 0
Thanked 1 Time in 1 Post
The orange is the engine block
D4Dartswinger is offline   Reply With Quote
Old 09-30-2017, 08:11 PM   #3
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 5,878
Thanked 442 Times in 438 Posts
That would do it !!! And your going to saw a hole in the oil line tubing also, might address that while your at it....
RacerHog is offline   Reply With Quote
Old 10-02-2017, 10:47 AM   #4
Mopar Fan
Thread Starter
 
D4Dartswinger's Avatar
 
Join Date: Dec 2016
Posts: 45
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by RacerHog View Post
That would do it !!! And your going to saw a hole in the oil line tubing also, might address that while your at it....
Is that plate on correctly? Or am I missing something that plugs that hole to the engine
D4Dartswinger is offline   Reply With Quote
Old 10-02-2017, 04:06 PM   #5
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 5,878
Thanked 442 Times in 438 Posts
You need a missing gasket/seal and to replace the broken off bolts... there are 3 bolts that secure the plate to the firewall...
RacerHog is offline   Reply With Quote
Old 10-02-2017, 07:17 PM   #6
Mopar Fan
Thread Starter
 
D4Dartswinger's Avatar
 
Join Date: Dec 2016
Posts: 45
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by RacerHog View Post
You need a missing gasket/seal and to replace the broken off bolts... there are 3 bolts that secure the plate to the firewall...
hmmm ok thanks I'll try to do some googles and figure out what those might be
D4Dartswinger is offline   Reply With Quote
Old 10-02-2017, 07:51 PM   #7
Mopar Lover
 
RacerHog's Avatar
 
Join Date: Jun 2013
Location: Monrovia SO-CAL (USA)
Posts: 5,878
Thanked 442 Times in 438 Posts
Something like this.. >>>>> https://www.ebay.com/i/260436315544?chn=ps&dispItem=1 <<<<<<

And look in the upper L.H. Hole... The mounting bolt is broken off inside the weld nut.
RacerHog is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
67 fury 3 after changing starter...still click click sound ahrkar Interior/Exterior Electrical 1 09-18-2012 10:27 AM
67 fury 3 "click click click" sound ahrkar Interior/Exterior Electrical 4 09-13-2012 08:03 PM
Contest time! Click here for free stuff!!!! 1 Bad Mirada General Discussion 3 09-14-2010 01:12 PM
weird pops sgp7679 General Discussion 21 04-11-2009 02:40 PM
weird lock youngtwister A-Body 3 12-27-2008 03:55 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 03:24 AM.